The fact that it's shallow is something that I just *KNOW* will come to bite me. Generally when the caffeine has worn off and the brain is going into power-saving mode.
@prepsure_2 ай бұрын
i think the idea here is that your classes are immutable. replace only really useful in this case, it’s a functional construct, so shallow copying shouldn’t be an issue because the data won’t be mutable anyway
@XxZeldaxXXxLinkxX2 ай бұрын
@@prepsure_yep you needed to have fucked up twice already if you're running into data consistency problems using immutable type classes 😂
@Libertarian12082 ай бұрын
There is a method dataclasses.replace (in Python 3.12 at least) - for dataclasses copy.replace is not needed
@martinpayne29342 ай бұрын
I think it has been around for as long as dataclasses have existed. It definitely exists in 3.10 anyway. But perhaps this more generalised version of replace is intended to replace (pun intended) the one in the dataclasses module.
@fyellin2 ай бұрын
There is also the method NamedTuple._replace. Does this new method do anything that can’t already be done?
@rustyguard10012 ай бұрын
@@fyellinit bacically unifies all the different replace methods with introduction of __replace__
@PeterZaitcev2 ай бұрын
@@martinpayne2934 since 3.7
@pharoah3272 ай бұрын
This is essentially the "with" keyword in C#. Glad to see Python getting this feature!
@ZelenoJabko2 ай бұрын
c# stole this feature from Scala.
@pharoah3272 ай бұрын
@ZelenoJabko languages "steal" from other languages all the time. It's nothing new. It's actually a very positive and healthy thing. Again, I'm glad to see Python "stealing" this feature as I think it can be very useful. I know I used C#'s version of it recently in a project and it was great.
@snesmocha2 ай бұрын
@@ZelenoJabkoevery language steals from lisp 💀
@soniclettuce2 ай бұрын
@@ZelenoJabko and Scala stole it from OCaml
@ecaltroyer2 ай бұрын
The KZbin algorithm has got you
@krol_zeliwko2 ай бұрын
"what am I even saying" 😂😂😂
@oida10000Ай бұрын
Is there an equivalent method for replace with deepcopy? Maybe deepreplace?
@rusca82 ай бұрын
I mean. The dataclasses module itself already has a replace function that works like that.
@ezkymos2 ай бұрын
What is the difference compared to using cup.copy(price=100) ?
@m4rcika2 ай бұрын
Really clear and useful, thank you
@23nine2 ай бұрын
I didn't even know about dataclasses. Thanks.
@seanshimon2 ай бұрын
You must
@samuelpinzon83292 ай бұрын
Python 3.13 has some good features, and I wanna learn it all!! But I still don't know most of the features of the past versions 😭😭😭😭
@ludovicbossard9577Ай бұрын
We all have to start somewhere
@Imperial_SquidАй бұрын
No coder knows every single feature of the languages they use, unless you're one of the people making it, it's not necessary.
@notanerd31412 ай бұрын
3:08 why use replace when you can just make a new instance?????
@joshix8332 ай бұрын
It would be more useful if the class had many you want to keep the same
@buycraft911miner22 ай бұрын
its super useful if you decide everything to be inmutable, which is common in functional programming
@stunnerr2 ай бұрын
That's just an example, real dataclass could have more fields than that
@seanshimon2 ай бұрын
Can you please show some Pytest examples and features, please.
@davidgillies6202 ай бұрын
I want to use 3.13 but too many packages have dependency issues still (I use miniconda for data wranglingstuff).
@sohangchopra64782 ай бұрын
Nice feature!
@adobko2 ай бұрын
Amazing as always
@immortalsun2 ай бұрын
Thanks for the video :)
@sectorgamma2 ай бұрын
So why isn't there a deep_replace the same way there is a deep_copy?
@joeldick6871Ай бұрын
How about deepreplace?
@shafqatjanjua48792 ай бұрын
Keep going... [for other whatever topics]
@Dulinniel2 ай бұрын
Genuinely, why would you change the value of an immutable object in a first place ? I mean, isn't there any dynamic data structure in python ?
@JNSchneider2 ай бұрын
This is not for changing values of immutable objects, if you want a mutable dataclass for instance, you just don't set frozen to true. The use case for this method is when you want to create a second immutable object that is similar to the first but slightly different. Since the object is immutable, you cannot make a copy and change it. Replace helps you create a copy that is different in the keys that you specify but still the same in all other properties and also immutable.
@foxypiratecove373502 ай бұрын
That's actually good.
@e-pluszak94192 ай бұрын
Price of type float, ouch 😳
@Indently2 ай бұрын
If your country doesn’t have coins you can always use an integer.
@e-pluszak94192 ай бұрын
@Indently yes, but if it does using floats is still insane due to rounding errors, Decimal class is the way to go
@yhtomit282 ай бұрын
@@e-pluszak9419 or another common trick with currency is to store it in terms of the smallest denomination and you always have a integer, e.g. for USD store an integer number of cents, or for GBP store an integer number of pence.
@lemonteurdesanuseur96862 ай бұрын
Anyone knows in what case this might be useful ?
@eternlyytc73002 ай бұрын
Thanks
@ItsJoeyG2 ай бұрын
this is HUGE
@Kynatosh2 ай бұрын
I don't use python much but from those examples I don't see the difference of using NamedTuple and dataclasses, what's the difference? Edit ah dataclasses are mutable by default, frozen=true makes them immutable. What's the difference then
@DuncanBooth2 ай бұрын
The fields in a named tuple may be accessed either by name or by index. Before named tuples existed functions such as os.stat() simply returned a ten element tuple. It still returns a ten element tuple for compatibility with old code but these days you wouldn't think of using anything but the named fields. Dataclasses are simply classes so they don't have any of the tuple baggage.
@Kynatosh2 ай бұрын
@@DuncanBooth So why would anyone use Frozen dataclasses if they are less permissive? I assume NamedTuples are faster too because c implementation and not dictionnary Edit: Actually, Maybe for typing it's good, because tuple NamedTuple1(x=1, y=2) == NamedTuple2(x=1, y=2) But Dataclass1(x=1, y=2) and Dataclass2(x=1, y=2) are different
@xbylina26412 ай бұрын
@@Kynatosh "Less permissive" doesn't mean "less usable" -- tuples are less permissive than lists and both have their uses.
@juanjosefarina2 ай бұрын
@@Kynatosh Mutability may result in ugly bugs, and using less permissive structures is recommended for a similar reason. You want to make as restricted and deterministic as possible your code.
@EndermanAPM2 ай бұрын
I like the feature, but don't really love the name. "replace" means replace, not "copy and replace". At least in my head.
@rubynaxela85242 ай бұрын
I've already answered another person who also didn't like the name, so I'll just copy my opinion here. A name like replaced() would be probably more consistent with functions like sorted() or reversed(). However that name could also suggest that we're somehow replacing the object itself, and not values of some of its fields, so perhaps a name like with_replaced() (or copy_and_replace()) would be even more transparent. But I think that at this point everyone has learned that Python functions (global or static, not instance methods!!), by convention, never modify their arguments and return modified, new objects instead, so there's probably no need for verbose names.
@chri-k2 ай бұрын
i would have called it new_from. but i also don't know anything about Python naming conventions.
@josejaimecome2 ай бұрын
Clear and Concise, that is why I always keep my self up to date with the new python release. But I try to not forget the old one as most of the code will be in old version.
@el_chivo99Ай бұрын
copy should be called shallowcopy and replace should have been some argument of shallowcopy, like a dictionary.
@WondrousHello2 ай бұрын
I don’t understand what the real world use case for this would be
@sseymour1978Ай бұрын
python 14 : deepreplace :D
@SarcTiann2 ай бұрын
You might want to write `golden_cup = replace(deepcopy(cup), cost=100)` Or `... deepcopy(replace( ...`
@MrKerim20002 ай бұрын
Should be called replaced instead of replace imo
@Omsip1232 ай бұрын
Hmmm, and copy would be copied? I think I see your point (which you did not explain), but I think replace is just fine as well.
@rubynaxela85242 ай бұрын
Yeah, I get it, it would be probably more consistent with functions like sorted() or reversed(). However that name could also suggest that we're somehow replacing the object itself, and not values of some of its fields, so perhaps a name like with_replaced() would be even more transparent. But I think that at this point everyone has learned that Python functions (global or static, not instance methods!!), by convention, never modify their arguments and return modified, new objects instead.
@pharoah3272 ай бұрын
@@rubynaxela8524always remember that new people are joining the field all the time and are learning Python for the first time. Consistency in naming is very important. Old hats will adapt but newbies will still be confused. Unfortunately I don't think Python language developers put near enough time into thinking about names and the inconsistency shows. So the distinction between replace and replaced or with_replaced is an important discussion that Python lang devs should have had.
@osamasrour47572 ай бұрын
❤❤❤❤
@aømid-GT2 ай бұрын
Is it weird that I Watch these Python vids even tho I use Lua?
@outofmemind2 ай бұрын
No, I mainly use rust
@MynameisBrianZX2 ай бұрын
nah I am not in a profession nor do I ever desire to casually use a statically typed language, but I still watch videos about them because peeks at language design is still interesting. People love tourism shows even if they’ll never travel.
@MichaelWoodrum2 ай бұрын
local myAnswer = setmetatable({}, { __tostring = function() return "yes" end }) print(tostring(myAnswer))
@outofmemind2 ай бұрын
The best thing about rust is converting strings to strings and u/isize to i32/64 and getting a panic error
@fswerneck2 ай бұрын
cool
@dipeshsamrawat79572 ай бұрын
Thank you 😊
@this-is-bioman2 ай бұрын
Naming a package just "copy" is pure evil.
@Baldur19752 ай бұрын
Das ist verwirrend. warum nicht copy.replace?
@MrKerim20002 ай бұрын
Einfach nur ein andere Art des imports?
@Baldur19752 ай бұрын
@@MrKerim2000 Ahh ok. replace wird ja von copy importiert und ist kein neues eigenes schlüsselwort. habe ich beim ersten schauen übersehen. Danke dir
@goid3142 ай бұрын
why can't we just do: point1 : Point = Point(x=1, y=1) point2 : Point = Point(x=5, y=1) ???
@juanjosefarina2 ай бұрын
If your class is as simply as Point, sure. If your class is big and complex you can make a deepcopy() and then change whatever attribute you need, but replace is more readable I guess