Join Showwcase, the social network built for developers - www.showwcase.com?referralToken=x0jj4ve6f8q
@elonfc2 жыл бұрын
Your videos always finds a top place in my KZbin home feed, and that why I'm here just 5 minutes after, loved to watch your video. Keep doing:)
@InternetMadeCoder2 жыл бұрын
Legend!!
@vamsichikkam2 жыл бұрын
Thanks a lot... You are helping me in learning new and correcting my mistakes in codes.
@InternetMadeCoder2 жыл бұрын
Happy to help
@BlazeTheCatMan8 ай бұрын
here are things that i learned on my own! 1 i already knew not to short name variables instead i always named them based off of what they do cuz i never liked people actually naming them short 2 i was repeating myself in code until i found out or realized that i could use the for i in range or for item in items for loop! 3 for cleaner code! if something i write works!? then i will keep it that way until i figure out or discover a shorter better way to write it! like for example the for loop or for i in range! and ill go and change it! 4 for the weird names that look like people just hit there keys! i never name my variables like this cuz i find it weird or hard to understand! i always believed in being descriptive when it comes to naming stuff
@EgoCheap2 жыл бұрын
Another great video dude. Very helpful
@InternetMadeCoder2 жыл бұрын
Glad you think so!
@rajajunaidf2 жыл бұрын
He always do great work! appreciated you! 🙂👍
@InternetMadeCoder2 жыл бұрын
Thank you 👍
@alexandrinamehandzhiyska69472 жыл бұрын
Thanks for the video! I believe it's really helpful for beginners. Regarding the code you started explaining at 2:56 - for lines 15 to 17, wouldn't it be cleaner if we removed the ternary operators? They seem redundant as we know that .endswith already returns a boolean. So we're basically receiving a boolean and then re-converting it to the same data type with the same value? I believe it would be more readable to just write is_correct_type = data.name.endswith('wav') or data.name.endswith('mp4').
@InternetMadeCoder2 жыл бұрын
oh yes you are absolutely right! That would be even better indeed!
@mattgriffiths42 жыл бұрын
What VS code theme is this? Really looking for a new theme that highlights key words clearly...
@atlanticx1002 жыл бұрын
Comments are king. Pain in the ## to write but a saver to you and your team hunting bugs.
@beingkentechke2 жыл бұрын
viewing this awesome video 20 minutes after being uploaded.. keep up the good work
@InternetMadeCoder2 жыл бұрын
🔥
@raj-cr4nl2 жыл бұрын
Great vid
@CallousCoder Жыл бұрын
Argument 1 “write code people or team understands” is lowering the bar to the weakest link in the team. An example, we had some Python (ugghhhh) scripts that had about a million transactions, it gotten a bit slow so I wrote a dispatcher that send every other request to another node. And I wrote: if i & 1 == 0: mq.Publish(node1, record[i]) else: mq.Publish(node2, record[i]) My colleague didn’t understand the logical and. I explained him that’s basically the same as a modulo 2 == 0 except it’s fast because it doesn’t do the divide and in a shitty language like Python modulo is slow! He changed the code to writing modulo because it was more understandable and the next day we didn’t meet the delivery time because the code ran 10 times slower 😂 Something I knew and had tested empirically. Same for example with
@InternetMadeCoder Жыл бұрын
Great points
@kiwingist28562 жыл бұрын
amazing stuff
@InternetMadeCoder2 жыл бұрын
🔥🔥🔥
@LiveKitchenDinu2 жыл бұрын
I have to develop time prediction system for bus route. I don't have enough knowledge to do it. Plzzz help me about AI and how to do it with Google API..🔥🔥🔥
@PakistanIcecream0002 жыл бұрын
what are the software tools you use to do the coding?
@mattgriffiths42 жыл бұрын
With Tip 2, I have tried the code out for myself (as below) and get this error "local variable 'sum' referenced before assignment" - can someone explain please? transactions = [203, 408, 23, 6, 87] sum = 0 def sum_of_transactions(transactions): for eachItem in transactions: sum += eachItem sum_of_transactions(transactions)
@mattgriffiths42 жыл бұрын
After much googling, I defined sum as global so it was not just in the function scope and that seems to work. Is this the best way of accomplishing this task?
@jadeisip83602 жыл бұрын
you can also just put the 'sum' variable inside the function.
@linamondal97272 жыл бұрын
Can you make a complete course on javascript???
@InternetMadeCoder2 жыл бұрын
I’m more a Python guy these days :(
@linamondal97272 жыл бұрын
Ok
@blindmanaction6201 Жыл бұрын
Is showcase free?
@ericng88072 жыл бұрын
That long if-statement actually isn't too bad imo lol
@InternetMadeCoder2 жыл бұрын
Haha I guess it’s not the worst example
@d.r17752 жыл бұрын
Do you have any guide to start with python?
@InternetMadeCoder2 жыл бұрын
I made a video on this
@karvapatel29982 жыл бұрын
What are you doing now in computer science?
@InternetMadeCoder2 жыл бұрын
Nand to Tetris, it's a course on computer systems / building a computer from scratch
@lyricsaroundmusic46932 жыл бұрын
Which one is best... Ztm or cs50 Pick one
@InternetMadeCoder2 жыл бұрын
cs50. But that one is only an introductory course, ZTM is what you can continue with after.
@lyricsaroundmusic46932 жыл бұрын
@@InternetMadeCoder thankyou and is it good to only stick with ztm after cs50?
@ConradLiebers2 жыл бұрын
How to I get job as coder?
@InternetMadeCoder2 жыл бұрын
get good
@iam31302 жыл бұрын
Basically I want to become a software developer and I taken admission in college for that but I am not able to pay for both, I can just pay my fees of college and so I am not able to buy a laptop for atleast 3 years, 🥺 bro can you please donate me your any old laptop , I want a laptop for coding. Please help me if possible, means alot for ♥️
@abdoue48652 жыл бұрын
Also you can add comments to the start of each code so people can understand what are you doing without need to understand the language